Erfahrungen beim Umstieg auf VoIP mit ISDN hinter einem WRT54GL

Allgemeines
Das Ergebnis nach fast zweijährigen Versuchen ist ernüchternd.
Das Einrichten der Telefoniererei ging relativ schnell. Sicherheitshalber wurden zunächst die Ports 5060-5080 und 3478-3479 an den ISDN-Adapter weitergeleitet. Damit waren Anrufe möglich, es klingelte! Aber nach dem Abheben gab es Schweigen auf beiden Seiten. Nach Weiterleiten der UDP-Ports 30000-31000 und 40000-41000 konnte man sich unterhalten. Genau nach 15 Minuten brach die Verbindung ab. Nach langem und aufwendigem Suchen im Internet und Untersuchung der im W724 intern verwendeten Ports wurde auch der Port 5004 weitergeleitet, und es war unbegrenztes Telefonieren möglich.
Alles im grünen Bereich? Denkste!
Die Anrufenden bekamen oft "Der Teilnehmer ist vorübergehend nicht erreichbar" oder einfach nur eine tote Leitung (also nichts) zu hören. Diesen Zustand habe ich nun fast zwei Jahre ertragen und viel probiert. Manchmal war das Internet regelrecht leer, ich habe alles weggelesen. :)
Das Problem liegt wahrscheinlich im fehlenden "Keep-Alive" im ISDN-Adapter. Er kann nicht selbständig die Verbindungsdaten durch den NAT-Router aufrechterhalten. Es fehlt der STUN-Client.
Wikipedia schreibt hierzu:
STUN ist ein auf UDP basierendes Client-Server-Protokoll. Es dient zur Ermittlung einer externen IP-Adresse und zur Analyse der Verbindung eines Clients zum Internet. Es ermittelt, ob NAT verwendet wird und welche NAT-Art vorliegt.

Die Mühen der vergangenen zwei Jahre sind hier abgelegt.

Das Ergebnis ist ein:
Zwangsrouter oder eine Fritzbox mit Doppel-NAT.
  • Zwangsrouter W724V der Telekom mit ISDN-Adapter und Doppel-NAT:
    Die Telefonie funktioniert ausgezeichnet, das IP-Forwarding funktioniert gar nicht !!!
    Liebe Telekom, das Internet wird nur nebenbei neuerdings zum Telefonieren mißbraucht. Da sollte das Internet mindestens noch wie bisher funktionieren !!!
  • Fritzbox 7170 mit vorgeschaltetem VDSL-Modem (Vigor 130):
    Die vorliegende FB7170 verliert nach etwa 20 Minuten Bereiche ihres FLASH-Inhalts. So ein Mist. Da muß nun eine "neue" her. Die Wahl fällt auf eine FB7272. Deren Energieverbrauch liegt ohne WLAN bei unter 6 Watt. Beschaffung ist ausgelöst .... (21.02.2018)
    ... und heute (18.03.2018) endlich eingerichtet. Die ganze Prozedur dauerte 20 Minuten, man will ja nichts falsch machen. Modem, FB und ein Testrechner wurden verbunden. Die Zugangsdaten wurden in der FB eingegeben. Nach etwa 10 Minuten leuchtete die DSL-LED des Modems. Nach Eingabe der Telefonnummern klingelte ein Telfon und nach Eingabe der weiterzuleitenden Ports, war der interne Webserver endlich wieder sichtbar. Was für eine Odyssee mit der Telekomtechnik.
    </beherrschung>
    Man sollte den W724V zusammen mit einem Haufen Sch.... in deren Zentrale schicken.
    <beherrschung>

Letzte Bearbeitung: 03. 06. 2018
4.3K Bytes